Fritz!Box-Gastzugang im IP-Client-Modus nutzen

Update vom 12.12.2015: Mit der aktuellen Laborfirmware (FRITZ!OS 06.36-32037 BETA) ist der Gastzugang auch im IP-Client-Modus verfügbar. Es gibt in dem Zusammenhang sogar eine neue Funktion:

Für ältere Versionen bleibt der Artikel aber vielleicht noch hilfreich.

Laut AVM ist „die Einrichtung des Gastzugangs nicht möglich“, wenn man eine Fritz!Box im IP-Client-Modus (zum Beispiel an einer anderen Fritz!Box) betreibt. Warum das so ist, erschließt sich mir nicht wirklich. Die einzige für mich plausible Erklärung wäre, dass die Abschottung der Gäste nicht perfekt funktioniert, weil die Route ins Internet einen weiteren (internen) Hop hat, an dem potenziell ein Ausbruch möglich ist. Da meine Gäste in der Regel vertrauenswürdig sind, möchte ich selber entscheiden, ob ich das Risiko eingehe.
Mit ein paar kleinen Eingriffen geht es nämlich doch…

Hinweis: In einigen Kommentaren wurde gemeldet, dass es im Gast-WLAN zu Problemen mit der IP-Vergabe kommt. Ich habe am 13.06.2015 eine Fritz!Box 7390 (FRITZ!OS 06.23) auf Werkseinstellungen zurückgesetzt, nochmal alles durchgespielt und keine Probleme festgestellt. Dabei habe ich die folgende Anleitung dann noch ein wenig angepasst (die Konfigurationssicherung entfällt). Zudem ist mir aufgefallen, dass der Gastzugang nach einem Neustart wieder deaktiviert ist. Bei einer Uptime von mehreren Monaten hatte ich das bisher nicht bemerkt… 😉

Vorausgesetzt wird, dass die Fritz!Box per Telnet erreicht werden kann!

Zur Vorbereitung wählen wir unter Internet->Zugangsdaten folgende Einstellungen:
Internetanbieter: Weitere Internetanbieter, Anderer Internetanbieter
Name: Beliebig
Anschluss: Anschluss an ein Kabelmodem
Betriebsart: Internetverbindung selbst aufbauen

Eventuell anschließend noch umstöpseln, um wieder auf das Webinterface zugreifen zu können:

„Mit Übernahme der Einstellungen wird die „LAN 1″-Buchse Ihrer FRITZ!Box zur WAN-Schnittstelle (Verbindung zum Internet).

Achtung:
Die Oberfläche Ihrer FRITZ!Box ist danach nur noch über WLAN, LAN 2, LAN 3, LAN 4 erreichbar.“

Jetzt wird unter WLAN->Gastzugang der Gastzugang nach Wunsch konfiguriert (auf die Punkte Push-Service und Internetanwendungen beschränken gehe ich unten noch ein).
Jetzt wird unter Internet->Zugangsdaten die Betriebsart auf IP-Client-Modus umgestellt, wodurch der Gastzugang deaktiviert wird:

In dieser Betriebsart steht die Funktion „WLAN-Gastzugang“ nicht zur Verfügung. Zur Zeit aktive Gastzugänge werden deaktiviert.

Tipp: Auf der Hauptbox unter Heimnetz->Netzwerk die IP der Zweitbox raussuchen.

Nun verbinden wir uns über Telnet mit der Fritz!Box und legen eine temporäre Datei an, die wir auch sogleich bearbeiten.
# vi /var/tmp/guest_ap.cfg

Jetzt mit „i“ in den Einfügemodus wechseln und die folgenden Werte eintragen:
wlancfg {
guest_ap_enabled = yes;
guest_pskvalue = "MeinGeheimesPasswort";
}

Wichtig: Das Passwort im Klartext eingeben und nicht aus der Konfigurationssicherung übernehmen!

Dann mit <ESC> den Einfügemodus verlassen und mit :wq <ENTER> die Datei speichern und schließen.
Zum Abschluss muss die WLAN-Konfiguration noch übernommen werden:
# wlancfgconv -M /var/tmp/guest_ap.cfg
# wlancfgchanged
(Quelle: IP-Phone-Forum)

Nach kurzer Zeit ist das Gäste-WLAN wieder wie vorab konfiguriert verfügbar.

Unter System->Push Service lässt sich der WLAN-Gastzugang noch aktivieren, sofern gewünscht. Die Funktion Internetanwendungen beschränken habe ich nicht ausprobiert, es sieht aber so aus, als wären hier Anpassungen an der user.cfg nötig.
Bei Bedarf also einfach mal wie gewünscht konfigurieren, eine Sicherung ziehen, wieder den IP-Client-Modus einschalten, erneut sichern und vergleichen.
Für die user.cfg scheint es allerdings keine *cfgconv und *cfgchanged Binaries zu geben – ich weiß nicht, ob es eine gute Idee ist, die /var/flash/user.cfg einfach so zu bearbeiten.
Wer es weiß oder (vielleicht erfolgreich) ausprobiert hat, kann hier gerne einen Kommentar hinterlassen…
Alternativ ist es hier vielleicht auch möglich, die Sicherung anzupassen und zurück zu spielen – wie man die dafür benötigte Checksumme ermittelt ist hier beschrieben.

41 Antworten auf „Fritz!Box-Gastzugang im IP-Client-Modus nutzen“

  1. Hallo Tobias,

    vielen Dank für deine Anleitung. Das ist genau das, was ich gesucht habe. Allerdings habe ich jetzt ein Problem. Als Router habe ich einen Speedport Hybrid. Die FritzBox Soll als WLAN-AP mit Gastzugang betrieben werden. Das funktioniert auch alles. Nur bekommen die Geräte im Gastzugang keine IP-Adressen vom Speedport (DHCP). Jetzt müsste ja theoretisch das DHCP in der FritzBox in einem anderen IP-Adressbereich aktiviert werden, um den Gästen eine IP zu geben.
    Weißt du wie das geht?

    Viele Grüße und vielen Dank für die Anleitung

    Loisomat

      1. Wenn ich mich im Gast-Wlan anmelden versuche anzumelden bleibt das Handy bei IP-Adresse beziehen stehen. Von daher nehme ich an, dass das Gerät keine IP zugewiesen bekommt.

        Vielen Dank für die schnelle Antwort

        1. Seltsam…
          Ich habe das mit unterschiedlichen Geräten getestet und keine Probleme.
          Hast du auch eine 7390?
          Sollen wir mal (per Mail) unsere (bereinigten) Konfigurationssicherungen vergleichen?

          1. Hallo Tobias
            Mit der Methode ist bei mir wie bei Loisomat noch keine IP Vergabe im Gastnetz möglich. (AVM FB 7490)
            Grund – der Nummerbereich 192.168. 1 7 9 .xxx ist in der cfg nicht vergeben.
            vermutlich müssen weitere Einträge in die cfg, zB.:
            ethinterfaces {
            name = „guest“;
            ipaddr = 192.168.179.1;
            is_guest = yes;
            interfaces = „wlan_guest“, „guest_ct*“, „guest_st*“;
            }

          2. ethinterfaces {
            name = „guest“;
            dhcp = no;
            ipaddr = 192.168.179.1;
            netmask = 255.255.255.0;
            dstipaddr = 0.0.0.0;
            interfaces = „wlan_guest“, „guest_ct*“, „guest_st*“;
            dhcpenabled = yes;
            dhcpstart = 0.0.0.0;
            dhcpend = 0.0.0.0;
            no_dnsd_static = yes;
            is_guest = yes;
            is_hotspot = no;
            }

          3. hätte meinen Kommentar hier direkt drunter schreiben sollen, dann hätte RTJ auch vermutlich eine Info bekommen, dass hier ein neuer Eintrag gekomme ist. Also nochmal:

            Ich habe des gleiche Problem. Die Fritzbox vergibt mir im Gastnetz keine IP Adresse.

            Als Box am Internetanschluss hängt bei mir eine FritzBox 7170 und an der 7490 möchte ich das Gäste-WLAN einrichten.

            @rtj: hat deine Lösung funktioniert? Was genau muss ich alles übernehmen?

          4. Hallo Tobias,
            ich habe das Thema jetzt etwas hängen lassen. Dennoch würde mich eine Lösung interessieren. Wir können gerne mal die configs austauschen.

            Grüße

            Loisomat

  2. Ich habe des gleiche Problem. Die Fritzbox vergibt mir im Gastnetz keine IP Adresse.

    Als Box am Internetanschluss hängt bei mir eine FritzBox 7170 und an der 7490 möchte ich das Gäste-WLAN einrichten.

    @rtj: hat deine Lösung funktioniert? Was genau muss ich alles übernehmen?

      1. Hallo Fabian,

        ich wollte meine Zweit-FB7390 mal auf Werkseinstellungen zurücksetzen und dann nochmal alles durchspielen.
        Momentan fehlt mir da allerdings die Zeit.
        Hast du es mal mit den Einstellungen von rtj probiert?
        LG
        Tobi

        1. wenn ich wüsste, welche der beiden Einstellungen die richtigen sind, würde ich das ja sofort machen.

          Bei mir ist der aktuelle Stand, dass ich ein WLAN sehe, aber keine IP Adresse bekomme. Die beiden Einträge von RTJ habe ich noch nicht eingepflegt weil ich nicht weiß, ob beide, oder nur einen oder was genau ich damit veränder…

  3. Hallo und erstmal vielen Dank für die wohl einzige Hilfe in diesem Problem und in dieser guten Qualität.
    Leider bin ich absoluter Laie und würde den Gastzugang trotzdem auch im IP Clienten Modus nutzen wollen.
    Also habe ich mich an der sehr genauen Anleitung entlanggehangelt und trotzdem wird mir die Möglichkeit des Gastzuganges nicht im Menü der Fritzbox 7490 angezeigt 🙁

    Kann mir bitte jemand helfen? Das wäre total nett.

    1. Hallo,
      wenn du deine FritzBox schon im IP-Client Modus laufen hast, kannst du den Gastzugang nicht im Menü anwählen. Das geht nur wenn deine FritzBox als Router konfiguriert ist. Stell deine FritzBox um, so dass diese als Router funktioniert (Standard-Modus). Du kannst deine FB auch einfach auf Werkseinstellungen zurücksetzen und dann die Anleitung nochmal durcharbeiten.

      Viele Grüße

      Loisomat

      1. Hallo Loisomat,

        Danke für Deinen Hilfeversuch.
        Es ist doch aber Bestandteil der o.g. Anleitung, dass ich den Clientenmodus deaktiviere bevor ich mit den entsprechenden Schritten weitermache. Folglich hatte ich den Clientenmodus auch nicht aktiviert, als ich die Punkte abgearbeitet habe.
        Es kamen keine Fehlermeldungen beim Abarbeiten, aber der Gastzugang bleibt weiter verborgen und wird nicht angezeigt.

        1. Durch den oben gezeigten „Hack“ bekommst du den Einträg im Webinterface auch nicht zurück, der Gastzugang allerdings wieder aktiviert, so dass du ihn mit der Telnet-Config nutzen kannst.

          1. Danke sc4ry für Deine Hilfe!!
            Das heißt, dass mir der Gastzugang nach dem „Hack“ zur Verfügung steht, ich die Auswahlfunktion über die Benutzeroberfläche der Fritzbox nicht zur Verfügung habe bzw. sie dementsprechend auch nicht sichtbar ist?
            Kannst du mir bitte beschreiben, wie ich den Gastzugang dann per telnet aktivieren soll? Die SSID wird jedenfalls nicht angezeigt.
            Es wäre mir wirklich wichtig den Gastzugang zu haben und bin total dankbar über diese Seite – nur leider fehlt mir noch der finale Durchbruch.. .-)
            Danke im Voraus!

            Telnet funktioniert übrigens wohl mit dem neuen OS6.30 nicht mehr- ist das richtig?

  4. Danke für die Anleitung. Ich habe nicht das Problem, dass ich keine IP bekomme, allerdings bleibt mein Problem, weshalb ich das Ganze überhaupt probiert habe, bestehen. Ich habe als Hauptrouter eine 7390 mit DHCP-Server. Über die 7360 wollte ich nun den Gastzugang aktivieren. Ich hatte bereits eine Konfiguration gefunden, die ähnlich funktioniert wie der IP-Client-Modus (Verbindung über einen Lan-Port) und zudem den Gastzugang zulässt, nachdem ich allerdings verbunden bin und eine IP aus dem Gästenetzwerk bekomme, habe ich dennoch keinen Zugriff auf das Internet.
    Hier weiß zufällig keiner eine Lösung, oder?

    Die Alternative Lösung zu diesem Hack (keine Ahnung ob das bereits bekannt ist), ist übrigens folgende Konfiguration:
    Internet Anbieter = weiterer Anbieter + anderer Anbieter
    Anschluss an einen DSL-Anschluss
    Werden Zugangsdaten benötigt = Nein
    Kapselung = Bridged + IP Adresse automatisch über DHCP beziehen

    Meiner Meinung nach identisch nutzerbar wie IP-Client Modus, allerdings ist der Gastzugang in Webinterface verfürbar.

    1. Soweit ich mich erinnere, gab es dann aber Einschränkungen, weil aus dem Netz der Hauptbox kein Zugriff in das Netz der Zweitbox möglich ist.
      Ich muss mich gezwungenermaßen in ein paar Tagen damit noch mal auseinander setzen, weil meine Hauptbox den Geist aufgegeben hat und durch eine 7490 ersetzt wird.
      Dann spiele ich alles nochmal komplett durch und bin gespannt, ob ich eine IP samt Internetzugang bekomme.

      1. Hey, ich habe auch noch einiges probiert und es ans laufen bekommen. Allerdings war dafür ein Downgrade der 2t Box (7360) auf FW 6.03 nötig.

        Fakt ist, es geht, nur die FW 6.20 scheint einen mehr zu beschränken als nötig.

        1. Schön, dass es bei dir jetzt auch geht.
          Ich habe es gestern nochmal mit einer 7390 (FRITZ!OS 06.23) ausprobiert und mit iOS, Windows Phone und Android keine Probleme bei der IP-Vergabe.

          Edit:
          Ich habe den ursprünglichen Beitrag jetzt noch etwas überarbeitet.

  5. Hallo
    kann ich den diese Anleitung auch nutzen und das ganze mit einer 7270 V2 machen.
    Diese gibt ja auch eine Gäste wlan raus bei dierekter Internet Verbindung.
    Danke für die Info werde mich da mal dran machen

  6. Es hat keinen Wert, ich muss mich doch mal erkundigen. Ich habe diese Konfiguration jetzt mehrmals mit einer 3270 v3 durch, FRITZ!OS 05.54. DHCP hab ich, aber das Routing für den Internetzugriff scheint nicht zu funktionieren. Gibt es dazu evtl. Lösungsansätze?

  7. Ich hab da dennoch eine Frage. Ich habe die aktuelle Firmware runter geladen. Gastzugang eingestellt, die SSID ist auf dem Handy ersichtlich. Wenn ich auf verbinden gehe, nach Eingabe des Schlüssels, baut sich kein Internet auf. Keine Verbindung , da keine IP vergeben wird. Kann mir jemand Helfen woran das liegt?

    1. Der Gastzugang vergibt eigentlich die IP Adressen automatisch. Erste Vermutung: Schlüssel falsch. Groß- und Kleinschreibung beachten. Vielleicht 0 (Null) statt O (Oh)? Wird auch Immerwieder gern genommen. Ist aber auch nur so ’ne 0815 Antwort. Normalerweise müßte es gehen.

      1. Ich habe das selbe Problem.
        Die 7490 ist hinter einem Speedport Hybrid.
        IP Adresse wird abgerufen und dann geht nichts mehr.
        Eingabefehler kann ausgeschlossen werden.

        Fritzbox-Version ist die 6.50

        1. Welchen Adressbereich verwendet ihr bei den Boxen?
          Ich habe die primäre Box seit eh und je auf 192.168.1.1 stehen und nie Probleme mit der IP-Vergabe gehabt.
          Die sekundäre Box lief für die Grund-Konfiguration auf 192.168.2.1 und nachher dann per DHCP mit einer 192.168.1.* Adresse.
          Wüsste zwar nicht, warum das ein Problem sein sollte (wenn ihr nicht gerade den Bereich 192.168.179.* verwendet), aber vielleicht stellt ihr die Hauptbox mal einfach um auf ein anderes Netz.

          1. Hallo.
            Also meine Fritzbox steht auf 192.168.2.9
            Im Menü Internet -> Zugangsdaten habe ich die IP fest vorgegeben.

            Der Speedport hat die 192.168.2.1.
            DHCP im Speedport ist AN. Bei der Fritzbox gibt es ja im IP-Modus keinen DHCP.

  8. Ich kann das Problem bestätigen, der Gastzugang vergibt keine IP Adressen.
    Lauf AVM geht es wohl nur, wenn die erste Box eine Fritzbox ist und selber die Verbindung aufbaut. Bringt mir jetzt nichts, da meine Hauptbox ein Speedport Hybrid ist.

  9. Hallo, war im Begriff eine 7490 zu bestellen als ich auf diesen Thread gestossen bin (danke dafür!). Mein jetziger Netgear WAC120 ist absolut unzuverlässing und die Fritzbox scheint mir gemäss div. Rezessionen am stabilsten zu sein (im Vergleich zu D-Link, TP-Link, Netgear, Asus, etc). Ich würde die Box als Access Point betreiben und Funktionen wie Gastzugang und WLAN Zeitsteuerung sind ein Muss. Kann mir jemand sagen ob der der Gastzugang mit der jetzigen Version 6.50 (glaube ich) möglich ist und auch funktioniert oder nicht (gemäss den letzten Kommentaren scheint dies eher nicht der Fall zu sein)? Falls ja, ist das zeitgesteuerte Ein/Ausschalten ebenfalls möglich im AP-Mode?

  10. Ich kann eure Erfahrungen auch nur Bestätigen. Ich habe zwei 7490er FB.
    -Fritz Box B ist auf „IP Client Modus“
    -Wenn ich die Option auf Box B „Gast W-Lan einstellungen aus Box A übernehmen“ einschalte, passiert einfach nichts. Die Gast-Wlan-Reichweite erhöht sich nicht.
    -Die reichweite das Standard W-LAN wird aber von Box B vergrößert.

    -Wenn ich die o.g. Option deaktiviere, kann ich das Gast-Wlan manuell einrichten. Dann funkt Box B auch das Gast-WLAn-Signal. Die Clients erhalten auch Gast-WLAN IP-Adressen, ABER: ich kann keine INternet seiten aufrufen.

    VOm AVM Support kam auch nichts hilfreiches

    1. Hi.

      Ich beschäftige mich auch schon seit geraumer Zeit mit dem Problem die Reichweiten des PrivatWLAN als auch des GastWLAN einer 7490 (v06.51) mittels einer LAN-Bridge (!!!) zu vergrößern.
      Meine Erfahrungen sind:

      1) Fritz!WLAN Repeater 1750E (v06.32):
      1.a) „Einstellungen für den Gastzugang aus der als Internet-Router genutzten FRITZ!Box übernehmen“ funktioniert schlicht und einfach nicht.
      1.b) Manuelle Konfiguration per „Gastzugang (privater Hotspot) aktivieren“ führt dazu, daß Geräte das WLAN zwar sehen und darauf verbinden können. Aber sie erhalten keine IP-Addresse.

      2) Fritz!Box 3390 (v06.30; IP-Client-Modus):
      2.a) Ein „Gastzugang“ kann in dieser Variante gar nicht konfiguriert werden.

      3) Fritz!Box 3390 (v121.06.36-32427 BETA; IP-Client-Modus):
      3.a) siehe 1.a)
      3.b) siehe 1.b)

      Ich habe natürlich bereits alles an AVM gemeldet, … Leider habe ich nach mehreren, sehr ausführlichen Diskussionen per E-Mail als auch Telefon zu verstehen bekommen, daß man mir „leider nicht weiterhelfen kann“.

      Meiner Meinung nach hat AVM derzeit ein riesiges Problem in der Produktentwicklung und im Produkttest.

      Grüße,
      D

  11. Bin per Zufall hier auf dem Artikel gestoßen.
    Habe eine ähnliche Situation, die ist wie folgt:
    Eine Glasfaserrouter dahinter eine 7490 als IP-Client und
    dahinter an lan 1 eine 7270v3 als IP Client und DECT Repeater mit FRITZ!OS 06.05
    Jetzt eine Frage, könnte den zumindest die 7270v3 mit dem Mod wieder ein
    Gastzugang aufbauen? Die 7490 kann (darf) es ja nicht. Ist schon heftig
    was der 7490 alles an Funktionen genommen wird, wenn sie nicht mehr als
    Router fungieren darf. Leider bietet der Netzanbieter mir an dem blöden GF-
    Router keinen Brigdemodus an.

    Gruß H

  12. Hallo Zusammen,
    Wie ich she bin ich nicht der einzigste mit diesem Problem, sprich 7490 Hauptrpoter, daran über Switch eine 7390 Fritzbox als Accespoint eingerichtet. Jetzt kurz den Gastzugang aktiviert und ausser das sich die Endgeräte mit dem Router verbinden passiert nichts. Hat jemand hier bereits eine Lösung ?
    Gruß Jan

  13. Ich habe ebenfalls die Probleme mit dem Gast-WLAN am IP-Client. Bei mir kommen folgende Komponenten zum Einsatz:

    Hauptrouter am VDSL: Fritzbox 7390 (FRITZ!OS 6.51)
    IP Client: Fritzbox 7330 (FRITZ!OS 6.50)

    Gastgeräte können sich mit dem Gast-WLAN an der 7330 verbinden, allerdings bekommen sie keinen Zugang ins Internet. Wenn man auf der 7330 im Menü WLAN => Funknetz nachschaut, dann sieht man diese Verbindung im Gast-WLAN. Als IP Adresse der Gastgeräte wird eine LAN Adresse aus dem internen Subnetz angezeigt. Diese kommt allerdings nicht beim Gastgerät an (und soll es auch gar nicht).

    Das Gast-WLAN der 7390 funktioniert dagegen einwandfrei. Die Gastgeräte bekommen eine IP Adresse aus einem separaten Subnetz, welches auch im Menü unter Heimnetz => Heimnetzübersicht => IPv4-Einstellungen angezeigt werden kann. Die 7330 bendient sich bei der Vergabe von Gast-IP-Adressen allerdings nicht aus diesem Subnetz.

    Hat jemand deswegen schon mal ein Ticket bei AVM aufgemacht?

    Gruß

    Michael

    1. Ich habe mich mit diesem Problem (IP im erweiterten Gastnetz nicht korrekt zugewiesen) an den Support gewandt und nach einigen Wochen wurde mir nun kommuniziert, dass das Problem mit Labor-Version FRITZ!OS 6.69-43367 auf dem Router behoben ist. Soweit von mir beurteilbar hat diese Version auch in der Tat das Problem behoben.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.